Requirements


The minimum system requirements for installing Verity K2 on any supported operating system platform are as follows:

512MB RAM

 

3GB disk space

 

800MHz or higher processor

 

400MB of space designated for /tmp or /var/tmp (UNIX), or user-defined temporary directory (Windows)

 

 

 
Note   Verity locales and gateways each have their own requirements, described in their own documentation. For more information, see the relevant guides, the Verity Locales Release Notes, and the Verity K2 Gateways Release Notes.
 

 


Supported Operating System Platforms

This section contains the versions and patches required for each operating system, as well as supported application servers and gateways.

 

 
Note   Verity K2 6.0 includes al K2 5.5 patches up through patch 21.
 

 

Operating system patches must be installed before you install K2.

 

Table 1-1    Operating system support in Verity K2 6.0 


Windows

 

 

 

Versions and Patches

Windows 2000 servers with Service Pack 3 or higher

Windows 2003 servers (Standard and Enterprise)

Note: The C runtime library msvcp60.dll is also required.

 

Gateways Supported

File System gateway

HTTP gateway

Lotus Notes gateway

ODBC gateway

Exchange gateway

Documentum gateway

SSL option

 

Web/Application Servers

Verity K2 6.0 Administration Web Server

Solaris

 

 

 

Versions and Patches

Solaris 2.8, 32-bit
Patch 108827-15, 109147-12, 108434-04 or later

Solaris 2.8, 64-bit
Patch 108435-04 or later

Solaris 2.9
Patch 111711-12 or later

/usr/lib/libCrun.so from Sun Workshop 6.0
/usr/lib/libCstd.so.1 from Sun Workshop 6.0

Note: UltraSparc only; K2 is not supported on x86.

 

Gateways Supported

File System gateway

HTTP gateway

Lotus Notes gateway

ODBC gateway

Documentum gateway

 

Web/Application Servers

Verity K2 6.0 Administration Web Server

AIX

 

 

 

Versions and Patches

AIX 5.1 with maintenance level 2

AIX 5.2 with maintenance level 1

 

Gateways Supported

File System gateway

HTTP gateway

Lotus Notes gateway

ODBC gateway

Documentum gateway

SSL Option

 

Web/Application Servers

Verity K2 6.0 Administration Web Server

HP-UX

 

 

 

Versions and Patches

HP-UX 11i (11.11) with the following patches:

PHKL_25729
signals, threads enh, Psets Enablement

PHCO_25452
libc cumulative patch

PHKL_25840
Thread NOSTOP, Psets, Thread abort

PHKL_25367

Priority inversion and thread hang

 

Gateways Supported

File System gateway

HTTP gateway

Documentum gateway

ODBC gateway

SSL Option

 

Web/Application Servers

Verity K2 6.0 Administration Web Server

Linux

 

 

 

Versions and Patches

Red Hat Linux Advanced Server V2.1
(VDK requires OS patch level up to 2.4.9-e62, which includes glibc-2.2.4-32.18)

Red Hat Linux Advanced Server V3.0

SuSE Linux 8.0 Enterprise Edition
(VDK requires OS patch level up to 2.4.21-138-smp, which includes glibc-2.2.5--21‘3)

SuSE Linux 9.0 Enterprise Edition

Note: The bc utility must be installed in order for K2 Installer or Locales installer to work correctly.

 

Gateways Supported

File System gateway

HTTP gateway

Lotus Notes gateway

ODBC gateway

SSL Option

 

Web/Application Servers

Verity K2 6.0 Administration Web Server



Software Dependencies

Some K2 components require that you have installed specific third party or other Verity software. You cannot use these K2 components until you satisfy the dependencies.

In some cases, the K2 installer displays a dialog with instructions to follow if you do not have the required software installed. In other cases, the installation stops. If this happens, you can exit the K2 installer and then return to the specific installation step after you install the third party software. Table 1-2 details the K2 software and feature dependencies.

 

Table 1-2    K2 Software Dependencies 


Component

Dependencies

K2 Java, Reporting

Windows, Solaris, Linux: JDK 1.4.2_07 (1.5 not supported)

HP-UX: JDK 1.4.2_04

AIX: Classic VM (build 1.4.2, J2RE 1.4.2 IBM AIX build ca142sr1aifx-20050413 (142SR1a + 82052 + 85266) (JIT enabled: jitc))

Business Console

Java Web Start 1.4.2_07 and above (1.5 not supported)

Indexing and viewing of SSL-protected Websites

Verity SSL Option

You must install either the 40 or 128 bit version of the Verity SSL Option in order to access SSL-enabled websites for indexing, searching and viewing.

K2 Dashboard
browsers

Netscape V7.x

Internet Explorer V6.x

K2 Documentation

When you install K2 Documentation, a K2 Server is configured and installed to serve the documentation collection.

Note: A .war file of the documentation is installed in data/docs for use with other application servers.

K2 services

K2 Administration Server

Non-English language capability

Verity Locales

If you require support for more than English, you must purchase and install the Verity Locales product. For more information on using Locales with K2, see the Verity Locale Configuration Guide.

ODBC Gateway

Microsoft Data Access Components (MDAC) 2.6 with SP1 or higher.

StyleSet Editor

Lotus Notes, Exchange, Documentum gateways:
K2 Services and K2 Dashboard must be installed (unless you run StyleSet Editor in stand-alone mode). Microsoft Management Console (MMC) 1.2 or above required. (Runs on Windows only.)

ODBC, File System, HTTP gateways
Verity Business Console must be installed and configured in addition to K2 Services and K2 Dashboard. (Runs on all platforms.)

Java/.NET Applications—
required packages

Java:

Java Runtime Environment 1.4.2_07 and above
(1.5 not supported)

.NET:

Microsoft .NET Framework SDK Version 1.1

Microsoft Visual J# .NET Version 1.1 Redistributable Package

Java/.NET Applications—
supported application servers

Apache Tomcat v5.0.28

Bea WebLogic 8.1

Sun One App Server 8

IBM WebSphere 5.1

Java/.NET Applications—
supported Web browsers

I.E. 5.0 or later

Netscape 4.8 - 7.2

Moselle Forfeits 1.0 or later

Moselle 1.7 or later

Opera 7.5

Safari 1.2